const regex = /(\S+?)\s*=\s*\"([^\t]+)\"\s*(?>;\s*\n)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S+?)\\s*=\\s*\\"([^\\t]+)\\"\\s*(?>;\\s*\\n)', 'g')
const str = `key_1= "vdsdsalh";
multiline_key = "something
with
many lines";
Key2 = "test with ; symbol";
`;
const subst = `^[#;].*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);