package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\(?\d{2}\)?)\s?(\d{5})-(\d{4})`)
var str = `79-91648966
79 99164-8966
(79)99164-8966
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}