re = /(\(?\d{2}\)?)\s?(\d{5})-(\d{4})/i
str = '79-91648966
79 99164-8966
(79)99164-8966
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end