const regex = /(\(?\d{2}\)?)\s?(\d{5})-(\d{4})/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\(?\\d{2}\\)?)\\s?(\\d{5})-(\\d{4})', 'gi')
const str = `79-91648966
79 99164-8966
(79)99164-8966
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}