$re = '/(\(?\d{2}\)?)\s?(\d{5})-(\d{4})/i';
$str = '79-91648966
79 99164-8966
(79)99164-8966
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);