// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(\(?\d{2}\)?)\s?(\d{5})-(\d{4})").unwrap();
let string = "79-91648966
79 99164-8966
(79)99164-8966
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}