import re
regex = re.compile(r"(\(?\d{2}\)?)\s?(\d{5})-(\d{4})", flags=re.IGNORECASE)
test_str = ("79-91648966\n"
"79 99164-8966\n"
"(79)99164-8966\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")