#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<a\s+(?![^>]*rel\s*=\s*(['"])\s*nofollow\s*\1)[^>]*href\s*=\s*(["'])http://www.mysite.com[][\w-.~:/?#@!%$&'()*+,;=]*\2[^>]*>"
Local $sString = "<a ... href="http://www.mysite.com/xyz...." ... >" & @CRLF & _
"<a ... href="http://www.mysite.com/xyz...." rel='nofollow' ... >" & @CRLF & _
"<a ... href="http://www.NOTmysite.com" ... >" & @CRLF & _
"<a ... href="http://www.mysite.com" rel='foobar'... >" & @CRLF & _
"<a class="use_same_protocol" href="//www.mysite.com" >" & @CRLF & _
"<!-- This used to great <a ... href="http://www.mysite.com/xyz...." ... > -->"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")