import Foundation
let pattern = ##"<a\s+(?![^>]*rel\s*=\s*(['"])\s*nofollow\s*\1)[^>]*href\s*=\s*(["'])http://www.mysite.com[][\w-.~:/?#@!%$&'()*+,;=]*\2[^>]*>"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<a ... href="http://www.mysite.com/xyz...." ... >
<a ... href="http://www.mysite.com/xyz...." rel='nofollow' ... >
<a ... href="http://www.NOTmysite.com" ... >
<a ... href="http://www.mysite.com" rel='foobar'... >
<a class="use_same_protocol" href="//www.mysite.com" >
<!-- This used to great <a ... href="http://www.mysite.com/xyz...." ... > -->
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)