import re
regex = re.compile(r"<a\s+(?![^>]*rel\s*=\s*(['\"])\s*nofollow\s*\1)[^>]*href\s*=\s*([\"'])http://www.mysite.com[][\w-.~:/?#@!%$&'()*+,;=]*\2[^>]*>")
test_str = ("<a ... href=\"http://www.mysite.com/xyz....\" ... >\n"
"<a ... href=\"http://www.mysite.com/xyz....\" rel='nofollow' ... >\n"
"<a ... href=\"http://www.NOTmysite.com\" ... >\n"
"<a ... href=\"http://www.mysite.com\" rel='foobar'... >\n"
"<a class=\"use_same_protocol\" href=\"//www.mysite.com\" >\n"
"<!-- This used to great <a ... href=\"http://www.mysite.com/xyz....\" ... > -->")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")