using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a\s+(?![^>]*rel\s*=\s*(['""])\s*nofollow\s*\1)[^>]*href\s*=\s*([""'])http://www.mysite.com[][\w-.~:/?#@!%$&'()*+,;=]*\2[^>]*>";
string input = @"<a ... href=""http://www.mysite.com/xyz...."" ... >
<a ... href=""http://www.mysite.com/xyz...."" rel='nofollow' ... >
<a ... href=""http://www.NOTmysite.com"" ... >
<a ... href=""http://www.mysite.com"" rel='foobar'... >
<a class=""use_same_protocol"" href=""//www.mysite.com"" >
<!-- This used to great <a ... href=""http://www.mysite.com/xyz...."" ... > -->";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}