import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\s+(?![^>]*rel\\s*=\\s*(['\"])\\s*nofollow\\s*\\1)[^>]*href\\s*=\\s*([\"'])http://www.mysite.com[][\\w-.~:/?#@!%$&'()*+,;=]*\\2[^>]*>";
final String string = "<a ... href=\"http://www.mysite.com/xyz....\" ... >\n"
+ "<a ... href=\"http://www.mysite.com/xyz....\" rel='nofollow' ... >\n"
+ "<a ... href=\"http://www.NOTmysite.com\" ... >\n"
+ "<a ... href=\"http://www.mysite.com\" rel='foobar'... >\n"
+ "<a class=\"use_same_protocol\" href=\"//www.mysite.com\" >\n"
+ "<!-- This used to great <a ... href=\"http://www.mysite.com/xyz....\" ... > -->";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}