#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\((?!\w+\))|(?<!\(\w\w\w)\)"
Local $sString = "Zinc Oxide (ZnO))" & @CRLF & _
"Zinc Oxide ((ghd))" & @CRLF & _
"Zinc Oxide (((ZnO))" & @CRLF & _
"Zinc Oxide (ZnO))" & @CRLF & _
"Zinc Oxide (ZnO)))"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)