using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((?!\w+\))|(?<!\(\w\w\w)\)";
string substitution = @"";
string input = @"Zinc Oxide (ZnO))
Zinc Oxide ((ghd))
Zinc Oxide (((ZnO))
Zinc Oxide (ZnO))
Zinc Oxide (ZnO)))";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}