import Foundation
let pattern = #"\((?!\w+\))|(?<!\(\w\w\w)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Zinc Oxide (ZnO))
Zinc Oxide ((ghd))
Zinc Oxide (((ZnO))
Zinc Oxide (ZnO))
Zinc Oxide (ZnO)))
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)