import re
regex = re.compile(r"\((?!\w+\))|(?<!\(\w\w\w)\)")
test_str = ("Zinc Oxide (ZnO))\n"
"Zinc Oxide ((ghd))\n"
"Zinc Oxide (((ZnO))\n"
"Zinc Oxide (ZnO))\n"
"Zinc Oxide (ZnO)))")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)