$re = '/\((?!\w+\))|(?<!\(\w\w\w)\)/';
$str = 'Zinc Oxide (ZnO))
Zinc Oxide ((ghd))
Zinc Oxide (((ZnO))
Zinc Oxide (ZnO))
Zinc Oxide (ZnO)))';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;