use strict;
my $str = 'Zinc Oxide (ZnO))
Zinc Oxide ((ghd))
Zinc Oxide (((ZnO))
Zinc Oxide (ZnO))
Zinc Oxide (ZnO)))';
my $regex = qr/\((?!\w+\))|(?<!\(\w\w\w)\)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";