// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^([A-F0-9]{40})$").unwrap();
let string = "FFFFFFFF9D491A33C59F4D37A505FAB092E8AFE0";
let substitution = "QuestionText = \"$1\",";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}