#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mix)^" & @CRLF & _
" (?:(?:\+|00)33[\s.-]?[67]|0[\s.-]?[67]) # Dialing code" & @CRLF & _
" (?:[\s.-]*\d{2}){4} # End of the phone number" & @CRLF & _
"$"
Local $sString = "0659507733" & @CRLF & _
"06 01 02 03 04" & @CRLF & _
"00330659507733" & @CRLF & _
"+336 01 02 03 04" & @CRLF & _
"00337 01 02 03 04" & @CRLF & _
"0033 7 01 02 03 04" & @CRLF & _
"0033 6 01 02 03 04"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")