const regex = /^
(?:(?:\+|00)33[\s.-]?[67]|0[\s.-]?[67]) # Dialing code
(?:[\s.-]*\d{2}){4} # End of the phone number
$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^
(?:(?:\\+|00)33[\\s.-]?[67]|0[\\s.-]?[67]) # Dialing code
(?:[\\s.-]*\\d{2}){4} # End of the phone number
$', 'gmi')
const str = `0659507733
06 01 02 03 04
00330659507733
+336 01 02 03 04
00337 01 02 03 04
0033 7 01 02 03 04
0033 6 01 02 03 04`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}