import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ " (?:(?:\\+|00)33[\\s.-]?[67]|0[\\s.-]?[67]) # Dialing code\n"
+ " (?:[\\s.-]*\\d{2}){4} # End of the phone number\n"
+ "$";
final String string = "0659507733\n"
+ "06 01 02 03 04\n"
+ "00330659507733\n"
+ "+336 01 02 03 04\n"
+ "00337 01 02 03 04\n"
+ "0033 7 01 02 03 04\n"
+ "0033 6 01 02 03 04";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}