# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^
(?:(?:\+|00)33[\s.-]?[67]|0[\s.-]?[67]) # Dialing code
(?:[\s.-]*\d{2}){4} # End of the phone number
$
"""
test_str = ("0659507733\n"
"06 01 02 03 04\n"
"00330659507733\n"
"+336 01 02 03 04\n"
"00337 01 02 03 04\n"
"0033 7 01 02 03 04\n"
"0033 6 01 02 03 04")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.