import Foundation
let pattern = ##"""
^
(?:(?:\+|00)33[\s.-]?[67]|0[\s.-]?[67]) # Dialing code
(?:[\s.-]*\d{2}){4} # End of the phone number
$
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
0659507733
06 01 02 03 04
00330659507733
+336 01 02 03 04
00337 01 02 03 04
0033 7 01 02 03 04
0033 6 01 02 03 04
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)