$re = '/^
(?:(?:\+|00)33[\s.-]?[67]|0[\s.-]?[67]) # Dialing code
(?:[\s.-]*\d{2}){4} # End of the phone number
$/mix';
$str = '0659507733
06 01 02 03 04
00330659507733
+336 01 02 03 04
00337 01 02 03 04
0033 7 01 02 03 04
0033 6 01 02 03 04';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);