#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(?:\D*\d){8}$)\d+(?:(?:-\d+){0,2}|(?:\s+\d+){0,1})$"
Local $sString = "12345678" & @CRLF & _
"1234 5678" & @CRLF & _
"1234-5678" & @CRLF & _
"123-45-678" & @CRLF & _
"12-345-678" & @CRLF & _
"" & @CRLF & _
"It should not accept these examples:" & @CRLF & _
"1234" & @CRLF & _
"123456789" & @CRLF & _
"-12345678-" & @CRLF & _
"!@@#$%" & @CRLF & _
"12ABCBDEF" & @CRLF & _
"12-34-56-78"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")