using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(?:\D*\d){8}$)\d+(?:(?:-\d+){0,2}|(?:\s+\d+){0,1})$";
string input = @"12345678
1234 5678
1234-5678
123-45-678
12-345-678
It should not accept these examples:
1234
123456789
-12345678-
!@@#$%
12ABCBDEF
12-34-56-78";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}