$re = '/^(?=(?:\D*\d){8}$)\d+(?:(?:-\d+){0,2}|(?:\s+\d+){0,1})$/m';
$str = '12345678
1234 5678
1234-5678
123-45-678
12-345-678
It should not accept these examples:
1234
123456789
-12345678-
!@@#$%
12ABCBDEF
12-34-56-78';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);