import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:\\D*\\d){8}$)\\d+(?:(?:-\\d+){0,2}|(?:\\s+\\d+){0,1})$";
final String string = "12345678\n"
+ "1234 5678\n"
+ "1234-5678\n"
+ "123-45-678\n"
+ "12-345-678\n\n"
+ "It should not accept these examples:\n"
+ "1234\n"
+ "123456789\n"
+ "-12345678-\n"
+ "!@@#$%\n"
+ "12ABCBDEF\n"
+ "12-34-56-78";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}