import re
regex = re.compile(r"^(?=(?:\D*\d){8}$)\d+(?:(?:-\d+){0,2}|(?:\s+\d+){0,1})$", flags=re.MULTILINE)
test_str = ("12345678\n"
"1234 5678\n"
"1234-5678\n"
"123-45-678\n"
"12-345-678\n\n"
"It should not accept these examples:\n"
"1234\n"
"123456789\n"
"-12345678-\n"
"!@@#$%\n"
"12ABCBDEF\n"
"12-34-56-78")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")