const regex = /^(?=(?:\D*\d){8}$)\d+(?:(?:-\d+){0,2}|(?:\s+\d+){0,1})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(?:\\D*\\d){8}$)\\d+(?:(?:-\\d+){0,2}|(?:\\s+\\d+){0,1})$', 'gm')
const str = `12345678
1234 5678
1234-5678
123-45-678
12-345-678
It should not accept these examples:
1234
123456789
-12345678-
!@@#\$%
12ABCBDEF
12-34-56-78`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}