# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?(DEFINE)(?<skip><ol>.*?<\\/ol>))(?&skip)(*SKIP)(*FAIL)|\s*<li\s+class="myclass">(.*?)<\\/li>\s*/<div class="newClass">$3<\/div>\n/gs;t' <<< "<ul>
<li class=\"myclass\">blablabla 1</li>
<li class=\"myclass\">blablabla 2</li>
<li class=\"myclass\">blablabla 3</li>
</ul>
<ol>
<li class=\"myclass\">blablabla 1</li>
<li class=\"myclass\">blablabla 2</li>
<li class=\"myclass\">blablabla 3</li>
</ol>
<ul>
<li class=\"myclass\">blablabla 1</li>
<li class=\"myclass\">blablabla 2</li>
<li class=\"myclass\">blablabla 3</li>
</ul>"