using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE)(?<skip><ol>.*?<\/ol>))(?&skip)(*SKIP)(*FAIL)|\s*<li\s+class=""myclass"">(.*?)<\/li>\s*";
string substitution = @"<div class=""newClass"">$3</div>\n";
string input = @"<ul>
<li class=""myclass"">blablabla 1</li>
<li class=""myclass"">blablabla 2</li>
<li class=""myclass"">blablabla 3</li>
</ul>
<ol>
<li class=""myclass"">blablabla 1</li>
<li class=""myclass"">blablabla 2</li>
<li class=""myclass"">blablabla 3</li>
</ol>
<ul>
<li class=""myclass"">blablabla 1</li>
<li class=""myclass"">blablabla 2</li>
<li class=""myclass"">blablabla 3</li>
</ul>";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}