#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)(?(DEFINE)(?<skip><ol>.*?<\/ol>))(?&skip)(*SKIP)(*FAIL)|\s*<li\s+class="myclass">(.*?)<\/li>\s*"
Local $sString = "<ul>" & @CRLF & _
" <li class="myclass">blablabla 1</li>" & @CRLF & _
" <li class="myclass">blablabla 2</li>" & @CRLF & _
" <li class="myclass">blablabla 3</li>" & @CRLF & _
"</ul>" & @CRLF & _
"<ol>" & @CRLF & _
" <li class="myclass">blablabla 1</li>" & @CRLF & _
" <li class="myclass">blablabla 2</li>" & @CRLF & _
" <li class="myclass">blablabla 3</li>" & @CRLF & _
"</ol>" & @CRLF & _
"<ul>" & @CRLF & _
" <li class="myclass">blablabla 1</li>" & @CRLF & _
" <li class="myclass">blablabla 2</li>" & @CRLF & _
" <li class="myclass">blablabla 3</li>" & @CRLF & _
"</ul>"
Local $sSubst = "<div class="newClass">$3</div>\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)