const regex = /(?(DEFINE)(?<skip><ol>.*?<\/ol>))(?&skip)(*SKIP)(*FAIL)|\s*<li\s+class="myclass">(.*?)<\/li>\s*/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)(?<skip><ol>.*?<\\\/ol>))(?&skip)(*SKIP)(*FAIL)|\\s*<li\\s+class="myclass">(.*?)<\\\/li>\\s*', 'gs')
const str = `<ul>
<li class="myclass">blablabla 1</li>
<li class="myclass">blablabla 2</li>
<li class="myclass">blablabla 3</li>
</ul>
<ol>
<li class="myclass">blablabla 1</li>
<li class="myclass">blablabla 2</li>
<li class="myclass">blablabla 3</li>
</ol>
<ul>
<li class="myclass">blablabla 1</li>
<li class="myclass">blablabla 2</li>
<li class="myclass">blablabla 3</li>
</ul>`;
const subst = `<div class="newClass">$3</div>\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);