import re
regex = re.compile(r"(?(DEFINE)(?<skip><ol>.*?<\/ol>))(?&skip)(*SKIP)(*FAIL)|\s*<li\s+class=\"myclass\">(.*?)<\/li>\s*", flags=re.DOTALL)
test_str = ("<ul>\n"
" <li class=\"myclass\">blablabla 1</li>\n"
" <li class=\"myclass\">blablabla 2</li>\n"
" <li class=\"myclass\">blablabla 3</li>\n"
"</ul>\n"
"<ol>\n"
" <li class=\"myclass\">blablabla 1</li>\n"
" <li class=\"myclass\">blablabla 2</li>\n"
" <li class=\"myclass\">blablabla 3</li>\n"
"</ol>\n"
"<ul>\n"
" <li class=\"myclass\">blablabla 1</li>\n"
" <li class=\"myclass\">blablabla 2</li>\n"
" <li class=\"myclass\">blablabla 3</li>\n"
"</ul>")
subst = "<div class=\"newClass\">$3</div>\\n"
result = regex.sub(subst, test_str)
if result:
print(result)