import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)(?<skip><ol>.*?<\\/ol>))(?&skip)(*SKIP)(*FAIL)|\\s*<li\\s+class=\"myclass\">(.*?)<\\/li>\\s*";
final String string = "<ul>\n"
+ " <li class=\"myclass\">blablabla 1</li>\n"
+ " <li class=\"myclass\">blablabla 2</li>\n"
+ " <li class=\"myclass\">blablabla 3</li>\n"
+ "</ul>\n"
+ "<ol>\n"
+ " <li class=\"myclass\">blablabla 1</li>\n"
+ " <li class=\"myclass\">blablabla 2</li>\n"
+ " <li class=\"myclass\">blablabla 3</li>\n"
+ "</ol>\n"
+ "<ul>\n"
+ " <li class=\"myclass\">blablabla 1</li>\n"
+ " <li class=\"myclass\">blablabla 2</li>\n"
+ " <li class=\"myclass\">blablabla 3</li>\n"
+ "</ul>";
final String subst = "<div class=\"newClass\">$3</div>\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}