#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<li>[\w\s]*word[\w\s]*<\/li>"
Local $sString = "<li>qweqwe sad qwe word </li>" & @CRLF & _
"<li>qweqwe sad qwe word </li>" & @CRLF & _
"<li>qweqwe sad qwe word </li>" & @CRLF & _
"<li>qweqwe sad qwe word</li>" & @CRLF & _
"<li>word</li>" & @CRLF & _
"<li> word</li>" & @CRLF & _
"<li>qweqwe sad qwe </li>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")