import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<li>[\\w\\s]*word[\\w\\s]*<\\/li>";
final String string = "<li>qweqwe sad qwe word </li>\n"
+ "<li>qweqwe sad qwe word </li>\n"
+ "<li>qweqwe sad qwe word </li>\n"
+ "<li>qweqwe sad qwe word</li>\n"
+ "<li>word</li>\n"
+ "<li> word</li>\n"
+ "<li>qweqwe sad qwe </li>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}