re = /<li>[\w\s]*word[\w\s]*<\/li>/
str = '<li>qweqwe sad qwe word </li>
<li>qweqwe sad qwe word </li>
<li>qweqwe sad qwe word </li>
<li>qweqwe sad qwe word</li>
<li>word</li>
<li> word</li>
<li>qweqwe sad qwe </li>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end