using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"src=\""\K.*(\/info[^']*)'[^\""]*";
string substitution = @"http://example.com$1";
string input = @"src=""http://example.com/javascript:gallery('/info/2005/image.jpg',383,550)""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}