import re
regex = re.compile(r"src=\"\K.*(\/info[^']*)'[^\"]*", flags=re.MULTILINE)
test_str = "src=\"http://example.com/javascript:gallery('/info/2005/image.jpg',383,550)\""
subst = "http://example.com$1"
result = regex.sub(subst, test_str)
if result:
print(result)