$re = '/src=\"\K.*(\/info[^\']*)\'[^\"]*/m';
$str = 'src="http://example.com/javascript:gallery(\'/info/2005/image.jpg\',383,550)"';
$subst = "http://example.com$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;