use strict;
my $str = 'src="http://example.com/javascript:gallery(\'/info/2005/image.jpg\',383,550)"';
my $regex = qr/src=\"\K.*(\/info[^']*)'[^\"]*/mp;
my $subst = 'http://example.com$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";