package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[1-9][2-9][0-9]\d{3,}|[1-9]\d{6,}`)
var str = `111
55
954
955
1000
0004
12000
120
999999
100000
120000
1200000
1000000
123456
222222
Log text: ajdlksjfds 120000 alskjdflskdf
Log text2: ajsldkfjsd 12000 alskdjflskdj
Log text 3: alskdjflskdjf 1000000 aslkdjflskdjf
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}