const regex = /[1-9][2-9][0-9]\d{3,}|[1-9]\d{6,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[1-9][2-9][0-9]\\d{3,}|[1-9]\\d{6,}', 'g')
const str = `111
55
954
955
1000
0004
12000
120
999999
100000
120000
1200000
1000000
123456
222222
Log text: ajdlksjfds 120000 alskjdflskdf
Log text2: ajsldkfjsd 12000 alskdjflskdj
Log text 3: alskdjflskdjf 1000000 aslkdjflskdjf
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}