import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[1-9][2-9][0-9]\\d{3,}|[1-9]\\d{6,}";
final String string = "111\n"
+ "55\n"
+ "954\n"
+ "955\n"
+ "1000\n"
+ "0004\n"
+ "12000\n"
+ "120\n"
+ "999999\n"
+ "100000\n"
+ "120000\n"
+ "1200000\n"
+ "1000000\n"
+ "123456\n"
+ "222222\n"
+ "Log text: ajdlksjfds 120000 alskjdflskdf\n\n"
+ "Log text2: ajsldkfjsd 12000 alskdjflskdj\n\n"
+ "Log text 3: alskdjflskdjf 1000000 aslkdjflskdjf\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}