using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([#\.][a-z0-9]*?\.?.*?)\s?\{([^\{\}]*)\}";
string input = @"#header { background: red; font-size: 14px; color:white; }
#header { background: red; font-size: 14px; color:white; }";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}