const regex = /([#\.][a-z0-9]*?\.?.*?)\s?\{([^\{\}]*)\}/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([#\\.][a-z0-9]*?\\.?.*?)\\s?\\{([^\\{\\}]*)\\}', 'gmi')
const str = `#header { background: red; font-size: 14px; color:white; }
#header { background: red; font-size: 14px; color:white; }`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}