$re = '/([#\.][a-z0-9]*?\.?.*?)\s?\{([^\{\}]*)\}/mi';
$str = '#header { background: red; font-size: 14px; color:white; }
#header { background: red; font-size: 14px; color:white; }';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);